Nur eine JQuery Version in WordPress laden

Wer sich mit WordPress beschäftigt, steht häufig vor der Problematik, dass mehrere Instanzen der JavaScript Bibliothek JQuery geladen werden.

Der Grund: verschiedene Plugins laden verschiedene Versionen. Die Folge ist ein schwerfälliges System. So werden Sie unnötige JQuery Instanzen los

Öffnen Sie in Ihrem Editor die Datei functions.php Ihres Themes (zum Beispiel TwentyEleven). Fügen Sie dort den folgenden Code ein:

//JQuery override
function my_scripts_method() {
wp_deregister_script( 'jquery' );
wp_register_script( 'jquery', 'https://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js');
wp_enqueue_script( 'jquery' );
}
add_action('wp_enqueue_scripts', 'my_scripts_method');

Sie sagen somit WordPress, dass nur die angegebene JQuery Version (in diesem Fall 1.7.2 von Google) geladen werden soll.

Das war’s… Sie müssen lediglich darauf achten, dass Ihre verwendeten Plugins auch mit dieser JQuery Version funktionieren.

Letzte Version vom 26. November 2018 von Netzgänger
Jetzt WordPress Newsletter in dein Postfach

Melde dich jetzt für meinen Newsletter an und du erhältst regelmäßig Tipps und Tricks zu WordPress in dein Postfach. Natürlich kannst du ihn jederzeit abbestellen.


4 Kommentare

  1. Sven sagt:

    Google bietet die libraries zeitgemäßerweise via https an. Um etwaigen redirects zu entgehen, rege ich an, dies in dem Snippet ebenfalls anzupassen.

  2. Maria sagt:

    Ok, das ist ein feiner Tipp. Wieso verwenden denn eigentlich alle einen unterschiedlichen Standard? Kann man das von WP Seite her nicht mal egalisieren?

    • Das wird WP nicht machen können. Unterschiedliche Pligins benötigen manchmal tatsächlich unterschiedliche JQuery Versionen. Nur eben meistens nicht. Und da liegt der Hund begraben…man muss also testen, wenn man die JQuery Versionen abspeckt. Läuft dann noch alles, so wie es soll? Laut meiner Erfahrung, ja. Aber Generalisieren kann man das schlecht…

Kommentar schreiben

Mit Absenden deines Kommentars erklärst du dich mit der Verarbeitung deiner hier angegebenen Daten einverstanden (Datenschutzerklärung). Diese werden nur zur Verwaltung der Kommentare verwendet und keinem anderen Zweck zugefügt. Du kannst jederzeit per E-Mail an info@netz-gaenger.de der Speicherung deiner Daten widersprechen.

* Notwendige Angaben

Netzgänger Webdesign | Rohrersmühlstraße 22 in Schwabach | Bayern
Kontakt: info@netz-gaenger.de
↑ oben
Inhalt